PDA

View Full Version : boot sequence problem


Doc
09-14-2006, 10:41 AM
I have an old Pentium II 233 box I'm trying to load Linux on. In the setup options it has the option to boot from A or CDROM ...as well as others. However when I change the setting and save it, and reboot it still boots from the c drive (old w 98 install). I see the CD drive light flash early on in the process but not before the actual boot. When I go back and check the settings in the SETUP window it shows the CD as being first boot option, so then I changed it to A booting first and get the same results.
It's an Abit MoBo.
Any ideas on how I might fix this?

jim slagle
09-14-2006, 10:50 AM
shell out to dos, then type "FORMAT C: /q /V[:empty]" just answer yes to all the dumb questions it will ask you. When it finishes you will have no problem with it booting from the hard drive.

by the way, :yankchain: :yum: :yum: :yum:

Jim

DaveNay
09-14-2006, 10:52 AM
I have an old Pentium II 233 box I'm trying to load Linux on. In the setup options it has the option to boot from A or CDROM ...as well as others. However when I change the setting and save it, and reboot it still boots from the c drive (old w 98 install). I see the CD drive light flash early on in the process but not before the actual boot. When I go back and check the settings in the SETUP window it shows the CD as being first boot option, so then I changed it to A booting first and get the same results.
It's an Abit MoBo.
Any ideas on how I might fix this?
Obvious stupid question....is there a bootable CD in the drive? A regular CD is not bootable. Believe it or not, there is actually an image of a 1.44MB floppy disk on a bootable CD.

edit: Another option is to unplug the HD power connector and try re-booting from the CD. This will tell you if it is at all possible to boot from that CD drive. I have come across some drives that don't like to be a boot device. Also, if you have a second IDE channel, move the CD drive to be the master device on that channel, and not a slave device on the first channel (HD being the master device). Two master devices on two channels is better than a master and slave on a single channel.

beds
09-14-2006, 10:53 AM
I had that problem with an ASUS board with w98. Sorry, I can't remember what the solution was, but I ended up formatting the drive that had 98 on it. Try unplugging the power to the drive and see where it tries to boot from. Also, does the bios recognize that the CDROM is actually a CDROM? I think I had problems when my original CDROM dies and it didn't recognize the burner that I was using as a CDROM.

Doc
09-14-2006, 11:00 AM
Thanks! Good ideas. I did have another cd drive in that box. I'm not sure whether I have the cd set to master for sure or not.
I tried multiple boot CD's (Red Hat disk 1 install CD) ...and the CD's work on other systems. The CD drive is an old Sony that did not have a tray to set the cd in. You push the cd in the slot much like a car cd player. I wondered if that got out of alignment. That's when I tried a bootable floppy. Still no go.
At least I have something to try now. Thanks for your thoughts. :thumb: