PDA

View Full Version : Kerosene heater repair


tsaw
11-29-2010, 08:48 PM
I have a 100,000 btu "salamander" kerosene heater in my garage. It stopped working properly.
However, what it does do is this:
Plug it in, and the fan and pump turn on ok.The igniter tries to light the burn. It is spaying the kero and it "PUFFS" flames as the thing is trying to light.
It lights - goes out.. lights goes out for maybe 15 to 20 seconds. Then the damn suborn thing gives up and trips the circuit breaker on the unit. I can press the button and try again. But the damn nutcase refuses to stay lit and burn.

Any Ideas on what the devil is wrong??

Cowboy
11-29-2010, 08:53 PM
Does it use a spark plug igniter Tom ? if so it may need cleaned or replaced . It also should have a doohicky that tells it when there is a problem with it & shuts it down , kind of like a photo sensor . Most times thats just covered with a film from the kero & can be cleaned off with a soft rag .

Some have a puter type board in them as well which can cause problems . What make & model is it & I might be able to be of some help . :wink:

Edit , it also could be an inlet or outlet filter thats plugged , The outlet filter is usually not cleanable & might need to be replaced . It should be located inside of where the inlet filter is & that box will need to come apart to replace it .

Cowboy
11-29-2010, 09:00 PM
Heres a link that might be of some help , Mine is a Desa 150K btu unit & no longer made but I can still get any parts for it . :smile:

http://www.masterparts.net/

tsaw
11-29-2010, 09:16 PM
Thanks for the info Bob.
It is a Reddy Heater model Pro 110
It's at least 10 years old. Never done a thing to it except add kero.:hammer: I can diagnose and fix most problem with engines, because i understand the fundamentals. But this is a different beast. Like refrigeration. I have no clue.

Cowboy
11-29-2010, 09:42 PM
Thanks for the info Bob.
It is a Reddy Heater model Pro 110
It's at least 10 years old. Never done a thing to it except add kero.:hammer: I can diagnose and fix most problem with engines, because i understand the fundamentals. But this is a different beast. Like refrigeration. I have no clue.


Yep Perty common & simple heater Tom . This should be the basic manual for it in pdf basicly the same heater as mine & should give you a clue to what could be causing the problem . But I perty much said the things I ussually find wrong .

http://www.bealsmotor.com/Desa%20Hot%20Surface%20Manual.pdf

I would remove the top & look into it further . Keep it away from anything & try to fire it without the lid on , that will let you see whats really going on . Halve a flashlite handy & the plug in your hand just in case something dont look right , :wink:

If you can snap a few pics with the cover off I can tell more about it . Probly be tommorow though as its past my bedtime :biggrin:

DaveNay
11-29-2010, 10:43 PM
Sounds like your injector bearing has a bad ground connection. :unsure:

muleman
11-30-2010, 04:21 AM
Quick lesson on the basics. It uses a single shaft motor to spin the fan and air compressor. The air compressor force air across a venturi tube which lifts the fuel from the tank and runs it through the nozzle. Most times the trouble will be in the filter on the fuel line coming from the tank. Just pull the line out of the tank and change it out. Most times Ace hardware has the parts in stock. The ignition is a coil firing a spark plug. It uses a cad cell to see the fire and shut it down if it does not light or when it runs out of fuel. The fan is just to blow the heat away from the chamber and out the end of the unit.

Cowboy
11-30-2010, 08:52 AM
I have a 100,000 btu "salamander" kerosene heater in my garage. It stopped working properly.
However, what it does do is this:
Plug it in, and the fan and pump turn on ok.The igniter tries to light the burn. It is spaying the kero and it "PUFFS" flames as the thing is trying to light.
It lights - goes out.. lights goes out for maybe 15 to 20 seconds. Then the damn suborn thing gives up and trips the circuit breaker on the unit. I can press the button and try again. But the damn nutcase refuses to stay lit and burn.

Any Ideas on what the devil is wrong??
After rereading this morning When you say the ignitor tries to light the burn I,m not quite sure I understand Tom . :neutral: When it is turned on the ignitor should imediatlly spark & constantlly maintain an arc , If it does not or its an intermitant arc it cant burn the fuel correctly & will spit & sputter & cause it to kick the reset button .

If you have the manual or look at the one I posted , check the correct setting for the ingnitor tip , It has to be set at the specific gap & the right distance from the nozzle as well as the correct angle . The biggest mistake most folks do is after removing the ignitor to clean or replace they put it back in to tight crushing the spacer that keeps the ignitor the correct distance .

It also has to be inline perfectly with the fuel spray , if its to tight it will not be efective enough as well as to loose , You can shim it out more by adding a spark plug type spacer or thin washer , but it has to be turned just right , if that makes sense . Best of luck & keep us updated :smile:

Adillo303
11-30-2010, 11:30 AM
Sorry for the mini hijack - Does anyone know who makes / made the Craftsman Salamander? Mine is working. I appreciate the parts link, Just trying to be ready.

Thank You

Cowboy
11-30-2010, 11:42 AM
Sorry for the mini hijack - Does anyone know who makes / made the Craftsman Salamander? Mine is working. I appreciate the parts link, Just trying to be ready.

Thank You


I,m not real sure who makes it for sears , But I think most are made by only a few companys & renamed . This links should get you any parts for it but you will need the model # , on the tag it may also have the makers brand name or logo . Hope that helps . :wink:
http://www.partsfor.com/
http://www.masterparts.net/

muleman
11-30-2010, 02:03 PM
Desa International made most of them regardless of the brand name. They went bankrupt in 2008 so I would have to hunt around for parts now. Mine used to come from down in a town west of Phila.

Cowboy
11-30-2010, 02:22 PM
Desa International made most of them regardless of the brand name. They went bankrupt in 2008 so I would have to hunt around for parts now. Mine used to come from down in a town west of Phila.
Yep , that second link lists all of the available parts as well as the technical info & Manuals . My big one is an older Desa model & I can get anything I need for it . :wink:

Adillo303
11-30-2010, 05:46 PM
Thank you reps all around.

tsaw
11-30-2010, 07:28 PM
After rereading this morning When you say the ignitor tries to light the burn I,m not quite sure I understand Tom I'm sorry. The igniter is working, because there are "puffs" of fire going on at the output end of the thing. But it never keeps burning. The Igniter keeps trying - and waiting for it to continue to burn. But it times out and shuts down. I will get the thing into a warm shop, disassemble, and report back later. I'm thinking fuel delivery problem based on what Bill said about the fuel filter. Makes sense... can't pick up enough kerosene... doen't light.. due to lack of fuel.. shuts down?

Thanks for all your help. :thumb:

Cowboy
11-30-2010, 07:54 PM
I'm sorry. The igniter is working, because there are "puffs" of fire going on at the output end of the thing. But it never keeps burning. The Igniter keeps trying - and waiting for it to continue to burn. But it times out and shuts down. I will get the thing into a warm shop, disassemble, and report back later. I'm thinking fuel delivery problem based on what Bill said about the fuel filter. Makes sense... can't pick up enough kerosene... doen't light.. due to lack of fuel.. shuts down?

Thanks for all your help. :thumb:

Tom if its the fuel screen you can pull the hose off of the nozzle & blow back through the line & it should clear itself out . I would also check the outlet on the nozzle because they are infamous for being covered with suet .

I use a light bristle brass wire brush to clean mine as well as the ignitor every few days in the winter because I run mine several hours a day . Just a thought if you dont have time to tear it down all the way . :wink:

ironaxe
02-25-2012, 09:42 PM
Tom, a couple things to try:
1. if its puffing, you have a air leak.
2. make sure the fuel cap is vented.
3. make sure you have the right pressure for your heater... you said 110,000 btu.. should be at 5.5-6 psi..

and this is important!!! check the fuel tank. Dirty fuel will kill a heater!!
try that, if your close to me in pa, and you cant get it working, bring it to my shop!!

Joe